Complex solver Error when trying to launch the game

I updated Essentials today, and I am now getting this error when I try to launch the game, do I need to update Quilt Loader, and if I do, how do I do that?

Unhandled solver error involving the following rules:
Rule 1:
optional mod ‘fabric-language-kotlin’ (3 sources)
- {org.quiltmc.loader.impl.plugin.quilt.QuiltModOption ‘qkl_core’ from /quilt-kotlin-libraries-1.0.2+kt.1.8.0+flk.1.9.0(1).jar!/META-INF/jars/quilt-kotlin-libraries-core-1.0.2+kt.1.8.0+flk.1.9.0.jar}
- {org.quiltmc.loader.impl.plugin.quilt.QuiltModOption ‘qkl_core’ from /core-2.0.2+kt.1.8.20+flk.1.9.3.jar}
- {org.quiltmc.loader.impl.plugin.fabric.FabricModOption ‘fabric-language-kotlin’ from /Essential Dependencies.jar!/META-INF/jars/[email protected]+kotlin.1.9.10.jar}
Rule 2:
Mandatory mod Quilt Kotlin Libraries: Core (qkl_core) v2.0.2
Rule 3:
Mandatory mod Essential Dependencies (essential-dependencies) v0
Rule 4:
Dependency for {org.quiltmc.loader.impl.plugin.fabric.FabricModOption ‘essential-dependencies’ from /Essential Dependencies.jar} on fabric-language-kotlin versions [>1.10.10+kotlin.1.9.10] (1 valid options, 2 invalid options)
+ {org.quiltmc.loader.impl.plugin.fabric.FabricModOption ‘fabric-language-kotlin’ from /Essential Dependencies.jar!/META-INF/jars/[email protected]+kotlin.1.9.10.jar} {org.quiltmc.loader.impl.plugin.fabric.FabricModOption ‘fabric-language-kotlin’ from /Essential Dependencies.jar!/META-INF/jars/[email protected]+kotlin.1.9.10.jar}
x provided mod ‘fabric-language-kotlin’ from {org.quiltmc.loader.impl.plugin.quilt.QuiltModOption ‘qkl_core’ from /core-2.0.2+kt.1.8.20+flk.1.9.3.jar} {org.quiltmc.loader.impl.plugin.quilt.QuiltModOption ‘qkl_core’ from /core-2.0.2+kt.1.8.20+flk.1.9.3.jar}
x provided mod ‘fabric-language-kotlin’ from {org.quiltmc.loader.impl.plugin.quilt.QuiltModOption ‘qkl_core’ from /quilt-kotlin-libraries-1.0.2+kt.1.8.0+flk.1.9.0(1).jar!/META-INF/jars/quilt-kotlin-libraries-core-1.0.2+kt.1.8.0+flk.1.9.0.jar} {org.quiltmc.loader.impl.plugin.quilt.QuiltModOption ‘qkl_core’ from /quilt-kotlin-libraries-1.0.2+kt.1.8.0+flk.1.9.0(1).jar!/META-INF/jars/quilt-kotlin-libraries-core-1.0.2+kt.1.8.0+flk.1.9.0.jar}

Essential is known to automatically install Fabric Language Kotlin, which is incompatible with Quilt Kotlin Libraries. Manually delete either one and it should work.

Edit: also just in case your version is simply outdated, make sure you are using either this one QKL 2.1.3 + FLK 1.10.10 + Kotlin 1.9.10 - Quilt Kotlin Libraries (QKL) if you are on 1.20.1. Or, if using FLK - Fabric Language Kotlin 1.10.10+kotlin.1.9.10 - Fabric Language Kotlin. Note: the main QKL file is version dependent and you might want to specifically download the core file if you are not on 1.20.1 (second on the page I linked).

so I play on a custom modpack, i deleted this one quilt-kotlin-libraries-1.0.2+kt.1.8.0+flk.1.9.0, but no dice it still gives me that error,

Yeah, I’m pretty sure you simply need to update it. Either grab the second file from the QKL link or the main file from the FLK link. And double-check that only one is present when launching.

sadly it didn’t work, i tried either, i deleted my qkl and replaced with the new one, crashed same error, so i deleted my core one and got the new one, same issue

Can you send your full latest.log file located in .minecraft/logs/ via, please?

i sent the crash report as my logs only mentions the crash and please check crash report :D, so i hope that works

You need to send me the resulting link after you upload the file. And if you don’t mind, still upload the latest log as well, because I want to take a look at your list of mods, but the crash reports that happen due to version incompatibilities don’t include them.

Quilt 1.19.2 Server Log [#PeMNm7c] -, i think i did this correctly lol, im new to this :smiley:

Yep, no worries. You need to remove the following files from your mods folder:
Then add this file
That should work. If still doesn’t work, upload new logs and send the new link.

tyvm that worked, thank you for your time :smiley:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.