Help us test our upgraded Maven!

Hello!

I’ve been experimenting with making the Maven much faster using some smart Cloudflare caching.

We need some people to test it and ensure everything is working fine before pushing it to production.

If you’d like to help, please add the following to your gradle.properties file:

loom_quilt_repository = "https://maven.quiltmc-testing.xyz/repository/release"

If you see anything wrong with the testing Maven, please let me know!

Do I need to put it above the other repos ?

You should only need to put that in your gradle.properties file and Quilt Loom should do the change for you

Changes have been applied to the production environment. Thanks to everyone who tested it!

Awesome, now I can’t launch newly installed Quilt versions since Maven is blocked in Russia

Russia is blocking all of Cloudflare? That seems… well, I guess a sledgehammer isn’t that surprising, actually.

On the other hand, this forum also uses Cloudflare. I’m not sure how you’re here, in that case.

Hey @Firestrike1, sorry for the inconvenience. Can you please navigate to https://maven.quiltmc.org/ and take a screenshot of that page? We will need more details to debug it.

No, Cloudflare isn’t blocked in Russia, the problem is that Maven forbids any Russian Ip’s. That’s what I believe, makes it impossible to download all the needed files. But I could be wrong, since the website you linked opens normally. Although I still can’t launch any version of Quilt I downloaded after the change.

That seems inaccurate, as Cloudflare IPs use anycast, they aren’t bound to a specific place on the internet. Do you have any Maven logs or something that can help us debug it?

[36m22:20:37,335 [ProxyRepo] Using proxy: https://maven.quiltmc.org/repository/release/org/quiltmc/quilt-loader/0.18.1-beta.26/quilt-loader-0.18.1-beta.26.jar
[39m22:20:37,335 [ProxyRepo] Resolved host maven.quiltmc.org: 172.67.163.83
[33m22:20:37,335 [ProxyRepo] Host is not whitelisted to use proxy: maven.quiltmc.org
[36m22:20:37,335 [DownloaderThread] Failed to download: https://maven.quiltmc.org/repository/release/org/quiltmc/quilt-loader/0.18.1-beta.26/quilt-loader-0.18.1-beta.26.jar

That looks like a configuration error on your side. I’ll let someone more experienced with Maven help you.

The exact same thing happens to 2 of my friends, and it started to happen exactly after you applied this upgraded Maven thingy. Nothing was changed in my launcher or internet connection since then.

Having done some checking around, it does appear that some ISPs in Russia do block all of our domains - looks like a blanket ban on the IPs we’re using. I’m not sure whether this is the problem here, though.

My question is where your ProxyRepo output is coming from.

The problem seems to have disappeared today when I tried to launch the same version and it suddenly started to work. I’m not too comfortable with sharing the full launcher log, but here is another part that I think is relevant:
[36m21:17:53,940 [DownloaderThread] Failed to download: https://maven.quiltmc.org/repository/release/org/quiltmc/quilt-loader/0.18.1-beta.26/quilt-loader-0.18.1-beta.26.jar
java.io.IOException: expected 200 response; got 403

It seems that my IP was getting blocked for whatever reason, but now I can access it without changing anything. Another interesting thing is that I tried to use VPN to avoid the block, but it didn’t work even though my location was shown as Netherlands on a site for location checking. I once tried to use VPN to avoid Maven blocking my IP and failing to load needed dependencies when I was trying to compile a mod, and it worked.

Sorry for not answering earlier, it seems like Cloudflare was blocking some IPs due to browser integrity checks failing. I’ve disabled that 12 days ago, before your comment, hopefully everything has been working since then?

Yes, everything worked fine since then.

1 Like