Tried Playing Mythical Cobblemon but it says Minecraft Failed to Launch

Anybody Know how to fix this issue?

---- Quilt Loader: Failed to load ----
Date/Time: 2023/09/14 20:05:08.4159

– Error 1 –

Unhandled solver error involving the following rules:
Rule 1:
optional mod ‘fabric-language-kotlin’ (3 sources)
- {org.quiltmc.loader.impl.plugin.quilt.QuiltModOption ‘qkl_core’ from /quilt-kotlin-libraries-1.0.2+kt.1.8.0+flk.1.9.0(1).jar!/META-INF/jars/quilt-kotlin-libraries-core-1.0.2+kt.1.8.0+flk.1.9.0.jar}
- {org.quiltmc.loader.impl.plugin.quilt.QuiltModOption ‘qkl_core’ from /core-2.0.2+kt.1.8.20+flk.1.9.3.jar}
- {org.quiltmc.loader.impl.plugin.fabric.FabricModOption ‘fabric-language-kotlin’ from /Essential Dependencies.jar!/META-INF/jars/[email protected]+kotlin.1.9.10.jar}
Rule 2:
Mandatory mod Essential Dependencies (essential-dependencies) v0
Rule 3:
Mandatory mod Quilt Kotlin Libraries: Core (qkl_core) v2.0.2
Rule 4:
Dependency for {org.quiltmc.loader.impl.plugin.fabric.FabricModOption ‘essential-dependencies’ from /Essential Dependencies.jar} on fabric-language-kotlin versions [>1.10.10+kotlin.1.9.10] (1 valid options, 2 invalid options)
+ {org.quiltmc.loader.impl.plugin.fabric.FabricModOption ‘fabric-language-kotlin’ from /Essential Dependencies.jar!/META-INF/jars/[email protected]+kotlin.1.9.10.jar} {org.quiltmc.loader.impl.plugin.fabric.FabricModOption ‘fabric-language-kotlin’ from /Essential Dependencies.jar!/META-INF/jars/[email protected]+kotlin.1.9.10.jar}
x provided mod ‘fabric-language-kotlin’ from {org.quiltmc.loader.impl.plugin.quilt.QuiltModOption ‘qkl_core’ from /core-2.0.2+kt.1.8.20+flk.1.9.3.jar} {org.quiltmc.loader.impl.plugin.quilt.QuiltModOption ‘qkl_core’ from /core-2.0.2+kt.1.8.20+flk.1.9.3.jar}
x provided mod ‘fabric-language-kotlin’ from {org.quiltmc.loader.impl.plugin.quilt.QuiltModOption ‘qkl_core’ from /quilt-kotlin-libraries-1.0.2+kt.1.8.0+flk.1.9.0(1).jar!/META-INF/jars/quilt-kotlin-libraries-core-1.0.2+kt.1.8.0+flk.1.9.0.jar} {org.quiltmc.loader.impl.plugin.quilt.QuiltModOption ‘qkl_core’ from /quilt-kotlin-libraries-1.0.2+kt.1.8.0+flk.1.9.0(1).jar!/META-INF/jars/quilt-kotlin-libraries-core-1.0.2+kt.1.8.0+flk.1.9.0.jar}

– Plugin State –

Cycle number = 1
Cycle Step = SOLVE

Loaded Plugins (2):

  • ‘quilt_loader’ (Builtin)
  • ‘quilted_fabric_loader’ (Builtin)

Fabric Language Kotlin and Quilt Kotlin Libraries are incompatible with each other, you must only install one. Essential is known to install FLK automatically, so you might have to manually delete it.

Edit: also just in case your version is simply outdated, make sure you are using either this one QKL 2.1.3 + FLK 1.10.10 + Kotlin 1.9.10 - Quilt Kotlin Libraries (QKL) if you are on 1.20.1. Or, if using FLK - Fabric Language Kotlin 1.10.10+kotlin.1.9.10 - Fabric Language Kotlin. Note: the main QKL file is version dependent and you might want to specifically download the core file if you are not on 1.20.1 (second on the page I linked).

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.