Trying to play mythical cobblemon but says minecraft failed to launch

---- Quilt Loader: Failed to load ----

– Error 1 –

Unhandled solver error involving the following rules:
Rule 1:
Dependency for {org.quiltmc.loader.impl.plugin.fabric.FabricModOption ‘essential-dependencies’ from /Essential Dependencies.jar} on fabric-language-kotlin versions [>1.10.10+kotlin.1.9.10] (1 valid options, 2 invalid options)
+ {org.quiltmc.loader.impl.plugin.fabric.FabricModOption ‘fabric-language-kotlin’ from /Essential Dependencies.jar!/META-INF/jars/[email protected]+kotlin.1.9.10.jar} {org.quiltmc.loader.impl.plugin.fabric.FabricModOption ‘fabric-language-kotlin’ from /Essential Dependencies.jar!/META-INF/jars/[email protected]+kotlin.1.9.10.jar}
x provided mod ‘fabric-language-kotlin’ from {org.quiltmc.loader.impl.plugin.quilt.QuiltModOption ‘qkl_core’ from /core-2.0.2+kt.1.8.20+flk.1.9.3.jar} {org.quiltmc.loader.impl.plugin.quilt.QuiltModOption ‘qkl_core’ from /core-2.0.2+kt.1.8.20+flk.1.9.3.jar}
x provided mod ‘fabric-language-kotlin’ from {org.quiltmc.loader.impl.plugin.quilt.QuiltModOption ‘qkl_core’ from /quilt-kotlin-libraries-1.0.2+kt.1.8.0+flk.1.9.0(1).jar!/META-INF/jars/quilt-kotlin-libraries-core-1.0.2+kt.1.8.0+flk.1.9.0.jar} {org.quiltmc.loader.impl.plugin.quilt.QuiltModOption ‘qkl_core’ from /quilt-kotlin-libraries-1.0.2+kt.1.8.0+flk.1.9.0(1).jar!/META-INF/jars/quilt-kotlin-libraries-core-1.0.2+kt.1.8.0+flk.1.9.0.jar}
Rule 2:
Mandatory mod Essential Dependencies (essential-dependencies) v0
Rule 3:
Mandatory mod Quilt Kotlin Libraries: Core (qkl_core) v2.0.2
Rule 4:
optional mod ‘fabric-language-kotlin’ (3 sources)
- {org.quiltmc.loader.impl.plugin.quilt.QuiltModOption ‘qkl_core’ from /quilt-kotlin-libraries-1.0.2+kt.1.8.0+flk.1.9.0(1).jar!/META-INF/jars/quilt-kotlin-libraries-core-1.0.2+kt.1.8.0+flk.1.9.0.jar}
- {org.quiltmc.loader.impl.plugin.quilt.QuiltModOption ‘qkl_core’ from /core-2.0.2+kt.1.8.20+flk.1.9.3.jar}
- {org.quiltmc.loader.impl.plugin.fabric.FabricModOption ‘fabric-language-kotlin’ from /Essential Dependencies.jar!/META-INF/jars/[email protected]+kotlin.1.9.10.jar}

– Plugin State –

Cycle number = 1
Cycle Step = SOLVE

Loaded Plugins (2):

  • ‘quilt_loader’ (Builtin)
  • ‘quilted_fabric_loader’ (Builtin)

what do i do?

now it says:

Fabric Language Kotlin requires version [0.14.21, ∞) of fabricloader, which is missing!

how do it fix this?

Send the full log please.

Simply updating Quilt loader to the latest stable version should solve this, that Fabric loader version is fairly old at this point, if I’m not mistaken.

how do i do that if im using a launcher?

Depends which launcher, but usually you go into your instance’s settings, find an option related to the modloader and change it from 0.19.x to 0.20.2.

its just giving me oracle versions?

Ok, could you clarify which launcher are you using?

technic, im trying to get the mythical cobblemon modpack

Sorry, I’ve never used this one and it seems to be the most convoluted way of installing a modloader I’ve ever seen. However, if I understand it correctly, you need to do the following:

  1. Go to this page and select your Minecraft version + Quilt loader 0.20.2
  2. Click “download version.json”
  3. In your Minecraft folder find a folder called “bin”, inside it find a file called “version.json” and rename it to “old_version.json”
  4. Copy and paste the file you downloaded in step 2 into the “bin” folder

If that doesn’t update it, then I’m afraid you’ll have to ask somewhere else.

thank you, it seems to work

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.