Nether Generates Structureless

I have individually tested all 30 mods and the 9 datapacks that I have been using to play and generating worlds and then reseting the nether trying to find the culprit as to why my nether will first not load me into it until I relog and then when I enter the nether there are no structures. I then took all of the exact same mods and datapacks and loaded them with the Fabric loader only substituting qfapi for fabric api so that it would load properly and it has solved the issue. I would really like to make a permanent move to quilt but need this issue to be fixed to do so. I have spent the last 5 hours trying to solve this. If there is anyway I can share my mod list with someone so that they can repeat this bug so that this can be fixed in the future I would love to do so. I love this loaders mission and want to see it succeed. After 5 hours of swapping mods one by one with no clear culprit I just need help.

Post your logs located in .minecraft/logs/latest.log here and send back the link. This will include the list of your mods and potentially some hints at what causes your problem.

Here is the link back to the posted Log thank you for your help.

OK, to say that you have an issue would be an understatement of the century :laughing: Your logs are getting heavily spammed by something, but, unfortunately, I can’t tell what exactly just by looking at it. Thankfully, your mod list is very light, so I will try to reproduce it shorty. For the time being, update your Quilt Loader to 0.19.2 release version, as you are currently using an old beta.

Yeah I have never had an issue like this one. Like I said in my first post I did a ton of trouble shooting and just could not for the life of me reliably narrow it down to a specific mod.

Alright, I just ran the exact modlist you have and did not run into this issue. I successfully entered the nether and ran a /locate command to find a fortress, which it did. This suggests, that one of your datapacks is likely at fault. Could you send a list of your datapacks?
I also noticed, that some of your mods are not up-to-date:
YACL - update to 3.0.3.
QSL - update to 6.0.4.
Jade - I personally used 11.2.0, but it’s marked as beta for some reason. Might still be worth updating, just in case.
FLK - update to 1.10.0.
Cloth Config - update to 11.1.106.
LazyDFU - technically no longer needed, Mojang drastically improved the DFU speed, but this mod is unlikely to cause any issues.
Starlight - also no longer needed and will not be supported in the long run, as Mojang has also made the lighting engine very efficient in vanilla.
Meanwhile, you could try removing all your datapacks, making a new world just for the test and trying to reproduce the issue. If it’s gone - it’s 100% one of your datapacks messing something up, potentially destroying existing worlds, even if you reset the Nether.

All of my Datapacks are from Vannilla Tweaks. Armour statues, Coordinates hud, Fast leaf decay, netherportal coords, Silence mobs, Track raw statistics, track statistics, vilager workstation highlight, and unpackable ice.

Hmmm… I assumed, you would have a bunch of worldgen datapacks. Alright, I’ll test them anyways, just to be sure. You can update the mods I listed for now and try again. I suspect updating Quilt loader and QSL would highly likely fix your issue. The rest should be up-to-date too, just in case.

Edit: just tried a new world with all the datapacks you listed, again everything went fine. Let me know if the issue still persists after updating all your mods and the loader.

I updated everything and it appears to be fine now thank you so much for your help. My problem world was a hardcore world that I have been streaming and after a day of not finding bastions or fortresses I was a little suspicious. When I watched back the vod and noticed no fossils in the soulsand valley I knew something was wrong. I got tunnel vision trying to salvage my world and got caught up trying to issolate the problem instead of thinking to update everything to solve the problem. Thank you so much for your help. You have been so kind.

Perfect! Glad it worked.

1 Like

Did the issue come back? Since you said it works with FAPI, I’d try reporting it to QFAPI on GitHub, because I’m completely out of ideas at this point.

No the issue is resolved it has been working fine ever since my post 6 days ago. I don’t understand how there is a post from 5 hours ago I did not do that.

Oh, no worries then.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.