Very strange crashes when loading resources 1.18.2

Console output:
0bin - encrypted pastebin

This crash happens randomly unless in a specific environment. It happens on:

  • Orcale JDK 17, Adoptium JDK 17, Microsoft JDK (together with Minecraft official launcher) 17
  • Minecraft 1.18.2
  • Windows 10, 11
  • Quilt 0.17.10

Sometime remove a resource pack can fix this bug, sometimes it crashes, sometimes it works fine.

Here’s what I’m seeing.

Non [a-z0-9/._-] character in path of location: create_crystal_clear:models/block/glass_encased_shaft/Originalblock.json

Consider removing whatever “create crystal clear” is and try again.

I tried to remove the mod, and the bug is fixed!

But I don’t think this will cause the crash.
Here is a normal load with this mod: 0bin - encrypted pastebin
The same error happens in the log, but it doesn’t cause a crash.

Hmm, does this mod allow you to register custom items/blocks, or change the IDs of anything it registers?

AFAIK, it does not.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.